Clientes Novell para Ubuntu versión 4.0 – Ubuntu Novell Client 4.0

Nota del 07/11/2011: Ya está disponible la versión 4.5

Debido a necesidades en mi entorno, he evolucionado los scripts para contemplar la posibilidad de que los usuarios puedan cambiar la contraseña. Se comprueba también la caducidad de la misma al hacer login y al intentar montar una unidad más. Si dicha contraseña está caducada se solicita al usuario que la cambie.

También se comprueban errores de autenticación al introducir un usuario/contraseña erróneos y se proporciona la información correspondiente al usuario.

Para finalizar, al hacer login, ahora es posible introducir sólo el nombre del usuario y después se nos muestra una lista de contextos generada mediante búsquedas en el LDAP. Por supuesto, es posible también introducir el camino completo al objeto del usuario como hasta ahora.

El fichero .tar.gz se puede descargar desde aquí durante un tiempo. Si pasado ese tiempo le interesa a alguien más, puede dejarme un msg y lo subo de nuevo en cuanto tenga un rato.

Saludos

Nota del 07/11/2011: Ya está disponible la versión 4.5

VUESTRA OPINIÓN SOBRE LOS CLIENTES

17 comentarios en “Clientes Novell para Ubuntu versión 4.0 – Ubuntu Novell Client 4.0

  1. Pingback: “Clientes Novell” para Ubuntu v 3.0 – Ubuntu “Novell Client” v 3.0 « La píldora roja

  2. Hola!
    Mira he estado probando tu programa de cliente novell, pero no he podido logearme al indicarle el nombre de usuario y contraseña me sale LOGIN FALLADO. ¿CONTRASEÑA INCORRECTA?.
    que puede estar pasando?.

    Gracias.

    Me gusta

  3. MAN me parece perfecto el laburo que te mandaste…
    y las actualizaciones constantes que vas haciendo…

    tengo un problema en particular, tengo una pc de 64bits.. y tu cliente solo funciona con 32… de casualidad armaste algun cliente para 64 bits ??

    desde ya muchas gracias
    Matias

    Me gusta

    • Hola Matias,

      de momento, en mi entorno, no tengo equipos con la versión de 64 así que no tengo pensado, por el momento, hacer una versión de 64 bits. De cualquier forma, en principio, yo creo que lo único que habría que hacer es poner la versión de 64 bits del paquete ncpfs_2.2.6-4ubuntu3_i386.deb, en el directorio “deb”, después de descomprimir el tar, y cambiar la línea del script “instalar” “sudo dpkg -i $instdir/deb/ncpfs_2.2.6-4ubuntu3_i386.deb” para que tenga el nombre del paquete de 64 bits (que en este momento no sé cual es). Después lanzar instalar.

      Saludos.

      P.s. Por favor, déjame un comentario si te funciona

      Me gusta

  4. Juan, no llegue a leer tu respuesta e instale una maquina virtual de prueba con ubuntu 32 bits…
    tengo un problemita…

    me puedo loguear correctamente con el script y me trae las unidades de forma satisfactoria. Pero cuando ingreso a las mismas no hay nada, me dice que tiene 0 items aunque el tamaño de la unidad se muestra con espacio ocupado por archivos.
    tenes idea de que puede estar pasando ??

    lo unico raro que note por asi decirlo, es que instale el ubuntu en idioma ingles porque es mas comodo para mi, pero el script del instalador me crea la carpeta ” escritorio ” y la carpeta ” red ” para hacer funcionar el cliente.
    tendra algo q ver esto ???

    aguardo tus comentarios
    desde ya y nuevamente gracias.
    saludos

    Me gusta

  5. ahi instale la version en español por las dudas…
    no cambio en nada obvio, pero quize probar.

    lo mismo q antes juanjo, tengo en home/xxxxx/red las unidades novell que mapie con el instalador. pero al ingresar no se ven carpetas ni archivos.
    estoy logueado en novell con el usuario administrador, por lo tanto tendria q ver todo ya que tiene permisos totales en las unidades.

    gracias
    matias

    Me gusta

    • En el campo de “login” ¿qué pones exactamente? Otra pregunta, durante la instalación te aparecieron servidores y volúmenes y los pudiste seleccionar correctamente? Sería util si me pudieses pasar el contenido de los ficheros del directorio “param”, dentro de .login_netware.

      Saludos

      Me gusta

  6. en el campo login, pongo el usuario administrador y el script me encuentra automaticamente el contexto con el “tomcat-rules” y luego ingreso la contraseña y me acepta el logueo correctamente.

    En la instalacion, veo los 4 servidores que tengo y veo todas las unidades de los mismos y los puedo seleccionar sin problemas.

    el file ” version ” dentro de la carpeta PARAM ( en el instalador )
    no tiene ningun parametro configurado solamente datos de la version y datos de comandos al estilo –help.

    pero aparte de ese file ” version ” no hay otro archivo.

    saludos y gracias por tu pronta respuesta.
    matias

    Me gusta

    • Algo raro hay…. En una instalación que funcione correctamente deben aparecer ficheros con todos los datos recabados (servidores, dominio, etc) durante la instalación. Por ejemplo, en uno de mis equipos, en el que, durante la instalación, elegí mapear dos unidades cada vez que haga login, puedes ver esto dentro del directorio param:

      rw-r–r– 1 ubuntu ubuntu 15 2011-01-03 11:49 dominio
      -rw-r–r– 1 ubuntu ubuntu 11 2011-01-03 11:49 ldapsrv
      -rw-r–r– 1 ubuntu ubuntu 2 2011-01-03 11:49 num_vol_inicio
      -rw-r–r– 1 ubuntu ubuntu 14 2011-01-03 11:50 servidor1
      -rw-r–r– 1 ubuntu ubuntu 14 2011-01-03 11:50 servidor2
      -rw-r–r– 1 ubuntu ubuntu 2 2011-02-22 10:53 ultimo_usuario
      -rw-r–r– 1 ubuntu ubuntu 41 2011-01-03 11:49 version
      -rw-r–r– 1 ubuntu ubuntu 7 2011-01-03 11:50 volumen1
      -rw-r–r– 1 ubuntu ubuntu 7 2011-01-03 11:50 volumen2

      En este punto no sé exactamente qué puede haber ocurrido, pero hay algo que no ha ido bien durante la instalación….

      Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s